Re: Compiling the onebillion and Kitkit software

@benmfoi Hi, Ben. Could you share more details about the problems you are encountering during the compilation process?

Also note that APKs are available for download from https://github.com/XPRIZE/GLEXP-Team-onebillion/releases and https://github.com/XPRIZE/GLEXP-Team-KitkitSchool/releases. Did you try downloading and installing those?


Jo

Hi,

I installed the kitkitschool apk files to my amazon fire tablet and they seem to work lovely for a short while, but then the device went into reboot mode. In the end I had to reset the tablet back to factory settings to get the fire device to work.

I installed the one billion software and that worked fine on the fire tablet, is still working and my grand-daughter enjoys using it.

I tried loading the kitkitschool APK files on to a Samsung tab 4 device and I can view the videos and books through the app, but the main app is not working correctly. Once the main intro video has finished and I click on the START button the app just throws a little error message, it just not processing any further. My next step is to look through the code in the repo and try work out why the code is not seeing the main library data.

Out of the two apps I believe the kitkitschool software is the better of the two teams. The interface looks better designed and a lot of development time has gone into the programming of the different apps.

Craig

To follow up from my previous post.

I installed the one billion main app apk file through the silk browser on the amazon fire tablet, then I followed the instructions as laid out in the Install-Standalone.md file for transferring the assets over to the tablet’s sdcard using the ADB program.

When I tried installing the main apk file from repo this way, the file would not install correctly and threw up errors with the package. Only by downloading and installing the apk file on the device did I get the software to work.

@CDavies Hi, Craig. What is the error message that you see?

Hi Jo,

When I click the Start button some text is displayed saying Error, that is it. When I initially installed the APK’s on a kindle device the software worked correctly for a time, so I believe it something to do with how the APK’s were installed under the different OS systems.

Craig

Hi Jo,

Be nice if I could put the APK’s on a sdcard and run them from there.

Craig

@CDavies Which Android OS version is installed on the Samsung tab 4 device? The information I have is that the Kitkit software should work on Android 4.4 and newer.

And what Android version is installed on the Kindle device?

@jo_xprize the version installed is 5.0.2.

@CDavies Would you be able to access the ADB log output while pressing the “Start” button?


adb logcat

That might give us some additional hints about exactly what caused the error.

Hi, kindle OS is 6.3. Will look into the log at function and come back to you. Many thanks for the help. Craig

@CDavies - were you able to fix the compilation issues with KitKit School? We are currently attempting this without success. A colleague of mine has opened an issue on Github regarding this too.

@tejpochiraju no still trying to solve issue.

@CDavies @jo_xprize - we have sent a pull request that fixes the build issues. We have tested that it builds with the latest Android Studio + SDK and runs on Android 9/X.